[RESOLU] Accents dans affichage d'un site

Trouvez ici tout l'aide dont vous avez besoin concernant le script d'annuaire Arfooo.
Merci de reporter les éventuels bugs trouvés.

[RESOLU] Accents dans affichage d'un site

Messagede chamagne » Mar 17 Déc 2013 05:39

Bonjour
Nouvelle instal, pas de pb, multiples tests en cours et customisation
Dernière version, language anglais

Problème :
Soumission d'un site avec description en français problématique

Soumission avec accents donne titre avec accents transformés (é) et description OK
Wallpapers Australie é New website
Fonds d'écran 1600x1200 sur l'Australie dont de nombreuses exclusivités (photos du webmestre): paysages, faune et flore...

Et dans le détail du site on a différemment (rien de bon !):
Fonds d'écran 1600x1200 sur l'Australie dont de nombreuses exclusivités (photos du webmestre): paysages, faune et flore...
Visit and enjoy the site Wallpapers Australie é, belonging to category Countries

La même chose en mettant le code pour les caractères accentués donne la même chose

Rien changé dans le code au niveau du jeu de caractères, ni de quelconques modifs des champs à ce sujet

Voir http://www.1600x1200-nature-wallpapers.com/arfoo/countries/

En complément : toute recherche accentuée ne va pas dans le tag cloud
Dernière édition par chamagne le Ven 20 Déc 2013 17:49, édité 1 fois.
chamagne
 
Messages: 9
Inscription: Dim 5 Sep 2010 19:02


Re: Accents dans affichage d'un site

Messagede chamagne » Mer 18 Déc 2013 06:17

Bonjour

Essai de solution

    1. Pour la description, encoder en UTF8 avant stockage en BD
    avec un htmlentities(description, ENT_NOQUOTES, "UTF-8") éventuellement suivi d'un htmlspecialchars_decode(description) si nécessaire
    Où et comment faire ça (j'avoue que le code "condensé" du script me pose pb) ?
    Ca marchera puisqu'un site modifié à coup de é par exemple, s'affiche correctement

    2. Pour le titre du site la même solution ne colle pas, un é s'affiche avec caractères bizarres, un é s'affiche en é
    Je ne vois d'autre solution que de ne pas avoir de caractères accentués, je m'en arrangerais à coup d'admin

Merci de votre aide
chamagne
 
Messages: 9
Inscription: Dim 5 Sep 2010 19:02

Re: Accents dans affichage d'un site

Messagede chamagne » Mer 18 Déc 2013 16:57

Bonjour

Et un pb important reste
Si la description est ainsi OK, elle ne l'est pas dans la page détails ???
J'arrête pour l'instant mes soumissions sur l'annu, inutile si je ne règle pas ce pb

HELP !
chamagne
 
Messages: 9
Inscription: Dim 5 Sep 2010 19:02

Re: Accents dans affichage d'un site

Messagede Hexa-67 » Ven 20 Déc 2013 16:10

Salut,
ceci t'aide-t-il? => topic888-10.html
Avatar de l’utilisateur
Hexa-67
 
Messages: 966
Inscription: Lun 1 Mar 2010 17:59

Re: Accents dans affichage d'un site

Messagede chamagne » Ven 20 Déc 2013 17:48

Bonjour

Ca marche, un grand merci
chamagne
 
Messages: 9
Inscription: Dim 5 Sep 2010 19:02


Retourner vers Installation, aide et report de bugs

 


  • Articles en relation
    Réponses
    Vus
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 0 invités

 
Copyright © arfooo.com  2007 - 2011  -  Tous droits réservés  -  Partenaires de confiance
Sites du groupe: petites annonces gratuites   voyance en direct - tirage tarot   Consultant en référencement
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group | phpBB SEO Traduction par: phpBB-fr.com
cron