Soucis avec les mails envoyés

Trouvez ici tout l'aide dont vous avez besoin concernant le script d'annuaire Arfooo.
Merci de reporter les éventuels bugs trouvés.

Soucis avec les mails envoyés

Messagede jeannotweb » Jeu 6 Mar 2008 10:27

Salut à tous,

Tout d'abord, toutes mes félicitations à Arf pour ce merveilleux script, superbe travail !!!

Alors, pour ma part l'installation c'est déroulée sans auncun problème, comme une jeune mariée oups !
Je suis chez ovh sur un 90plan.

Mon soucis, c'est la config des mails.
Comment faut-il faire pour avoir un email convenable ( email de confirmation reçu après inscription)
Si je ne met pas de [<br>] tout apparait sur une seul ligne !
Si je place le br pour le retour de ligne il apparait dans le mail !
Exemple :
Bonjour,
<br /><br />
Nous avons bien enregistrer la soumission de votre site [site name]
<br />

Idem avec les mots accentués
exemple :
si celui-ci convient aux normes et aux critères très strictes de sélection

et si je tape les accents aux normes xhtml j'obtiens :
si celui convient aux normes et aux crit&egrave;res tr&egrave;s strictes de s&eacute;lection, l'administrateur d&eacute;cidera alors de son indexation ou non dans la base


Et enfin, le [site name] à t-il réellement une fonction car il apparait tel que dans le mail..?

Cordialement, Jeannotweb
Cordialement, Jeannotweb
http://actublog.no-ip.be
jeannotweb
 
Messages: 150
Inscription: Mar 4 Mar 2008 08:55
Localisation: Liege - Belgique


Re: Soucis avec les mails envoyés

Messagede Arf » Jeu 6 Mar 2008 12:57

Tu parles des mails qui se trouvent dans configuration -> Texte -> emails ?

J'ai bien l'impression ^^ alors tu n'as pas besoin de mettre de <br />
Tu as juste à appuyer sur entrer pour aller à la ligne et à chaque fois que tu appuieras, tu iras à la ligne.

Pour les caractères spéciaux, c'est plus complexe, en France tu as majoritairement de l'encodage en iso8859-1 et mon Arfooo utilise l'encodage utf8 donc pour satisfaire tout le monde c'est compliqué.

Faudrait que je vois si je peux mettre une sélection d'encodage pour les emails pour convertir avant l'envoi.
Après tu peux pour l'instant éviter les éèà etc pour ne pas avoir de problème.

Après certains gestionnaire d'email détecte un mauvais encodage et te propose d'en changer, ce qui est pratique mais tous ne le font pas malheureusement.


Pour Votre site "[site name]" alors non il n'apparait pas tel quel, pour moi c'est le nom du site qui apparait dans le mail...
Pour tous les emails, il apparait en [site name], tu as modifier quoi exactement ?
Juste les emails à cet endroit ?
Arf
Administrateur du site
 
Messages: 3088
Inscription: Lun 21 Jan 2008 14:53

Re: Soucis avec les mails envoyés

Messagede jeannotweb » Jeu 6 Mar 2008 13:31

Salut arf,

Tu parles des mails qui se trouvent dans configuration -> Texte -> emails ?
J'ai bien l'impression ^^ alors tu n'as pas besoin de mettre de <br />
Tu as juste à appuyer sur entrer pour aller à la ligne et à chaque fois que tu appuieras, tu iras à la ligne.

Oui je parlais bien de la configuration pour les mails, j'ai tester avec le <br /> et comme je le signalais, il apparait dans le mail reçu, alors j'ai tester sans mettre les <br /> comme tu le recommandes ici mais tout se retrouve sur une seul ligne dans le mail reçu, c'est ce que je ne comprend pas !!!
Les retours de ligne ne sont pas pris en compte...

Pour les accents, ok on peut s'en passer pour l'instant c'est pas grave.

Pour Votre site "[site name]" alors non il n'apparait pas tel quel, pour moi c'est le nom du site qui apparait dans le mail...
Pour tous les emails, il apparait en [site name], tu as modifier quoi exactement ?
Juste les emails à cet endroit ?

Alors, après l'installation j'ai soumis un de mes sites pour tester, le mail que j'ai reçu était exactement comme ceci :
Code: Tout sélectionner
Bonjour,
<br /><br />
Nous avons bien enregistrer la soumission de votre site [site name]
<br />
si celui convient aux normes et aux critères très strictes de sélection, l'administrateur décidera alors de son indexation ou non dans la base.
<br /><br />

Je n'ai rien modifier d'autre que le mail qui était préconfigurer par défaut dans le champ prévu cet effet !
C'est pourquoi je posais la question...
Cordialement, Jeannotweb
http://actublog.no-ip.be
jeannotweb
 
Messages: 150
Inscription: Mar 4 Mar 2008 08:55
Localisation: Liege - Belgique

Re: Soucis avec les mails envoyés

Messagede Arf » Jeu 6 Mar 2008 15:46

Tu as modifier quel email exactement pour ce que tu me cites ?

Car la phrase qui dit que le site vient d'être soumis ne se trouve pas dans la base de données mais dans le fichier langue.

Il y a que 3 emails dans la configuration

Faudrait que je les regroupes tous, ce serait plus pratique.
C'est ce que je vais faire d'ailleurs, ce sera plus simple.

Sinon, tu as essayé de réinstaller car ton bug est très étrange.
Ou de renvoyer tes fichiers.
Car je viens de tester en réinstallant Arfooo avec l'archive que j'ai téléchargé et je n'ai aucun problème.
Arf
Administrateur du site
 
Messages: 3088
Inscription: Lun 21 Jan 2008 14:53

Re: Soucis avec les mails envoyés

Messagede jeannotweb » Jeu 6 Mar 2008 15:57

Oui c'est bien les 3 mails dans la config.
Je n'ai pas touché aux fichiers, mais ne serais-ce pas dû à Internet Explorer qui ne respecte pas tellement les normes... tu as qui comme navigateur toi ?
Parceque bon j'administre un petit réseau d'annuaire et j'ai la même blague avec les scripts de Freeglobes et Categorisator pour les retours de ligne !!!
Cordialement, Jeannotweb
http://actublog.no-ip.be
jeannotweb
 
Messages: 150
Inscription: Mar 4 Mar 2008 08:55
Localisation: Liege - Belgique

Re: Soucis avec les mails envoyés

Messagede Arf » Jeu 6 Mar 2008 16:05

Je test avec tout moi :)
IE6, IE7, FF, Opera :)

ça dépend peut être de ton logiciel de mail ?
Moi ça passe avec hotmail, webmail...

Tu as quoi comme héergement ?
Arf
Administrateur du site
 
Messages: 3088
Inscription: Lun 21 Jan 2008 14:53

Re: Soucis avec les mails envoyés

Messagede jeannotweb » Jeu 6 Mar 2008 16:27

ben j'ai Vista avec Windows mail -- IE7
Hébergement = ovh 90plan
Cordialement, Jeannotweb
http://actublog.no-ip.be
jeannotweb
 
Messages: 150
Inscription: Mar 4 Mar 2008 08:55
Localisation: Liege - Belgique

Re: Soucis avec les mails envoyés

Messagede Arf » Jeu 6 Mar 2008 20:13

J'ai exactement le même hébergeur et la même formule.

Tu as essayé avec hotmail ou le webmail chez OVH ?
Car je ne vois pas le rapport entre le service de mail et le problème que tu rencontres.

Car pour transformer [site name] j'ai mis un filtre donc une fois envoyé le mail est transformé.
C'est super bizarre.
T'as déjà eu le même problème avec un autre script ? :?
Arf
Administrateur du site
 
Messages: 3088
Inscription: Lun 21 Jan 2008 14:53

Re: Soucis avec les mails envoyés

Messagede jeannotweb » Jeu 6 Mar 2008 20:48

Car pour transformer [site name] j'ai mis un filtre donc une fois envoyé le mail est transformé.
C'est super bizarre.

Oui c'est bizarre !
Voilà exactement ce que je viens de recevoir pour le dernier site que je viens de soumettre
Bonjour,

Nous avons bien enregistrer la soumission de votre site [site name]

si celui convient aux normes et aux criteres tres strictes de selection, l'administrateur decidera alors de son indexation ou non dans la base.

Vous pouvez egalement proposer votre site dans nos autres annuaires :

http://world.mediannuaire.be
http://media-sport.mediannuaire.be
http://Gigannuaire.mediannuaire.be
http://media-voyage.mediannuaire.be
http://www.mediannuaire.be/annuaire
http://media-loisirs.mediannuaire.be
http://media-directory.mediannuaire.be
http://media-masterweb.mediannuaire.be

*****************
Pour faire des rencontres
http://media-rencontre.mediannuaire.be/index.php?l=fr


Ainsi libellé je n'ai aucune indication, je ne sais pas quel site vient d'être soumis !!!
Je ne sais pas, mais n'aurait-il pas été plus simple de faire les pages de config des mails en html comme Freeglobes par exemple ?
Cordialement, Jeannotweb
http://actublog.no-ip.be
jeannotweb
 
Messages: 150
Inscription: Mar 4 Mar 2008 08:55
Localisation: Liege - Belgique

Re: Soucis avec les mails envoyés

Messagede Arf » Jeu 6 Mar 2008 21:58

C'est le mail que reçoit l'administrateur ?
Ou le mail que reçoit le webmaster quand il vient de soumettre son site ?

Oui il a plusieurs possibilités.
C'est juste qu'il faut bien faire attention avec le html et bien filtré pour ne pas avoir de problème d'injection.

Tout peut être modifié.
Je ferais au mieux selon les indications de chacun.
Arf
Administrateur du site
 
Messages: 3088
Inscription: Lun 21 Jan 2008 14:53

Suivante

Retourner vers Installation, aide et report de bugs

 


  • Articles en relation
    Réponses
    Vus
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 0 invités

 
Copyright © arfooo.com  2007 - 2011  -  Tous droits réservés  -  Partenaires de confiance
Sites du groupe: petites annonces gratuites   voyance en direct - tirage tarot   Consultant en référencement
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group | phpBB SEO Traduction par: phpBB-fr.com