[Résolu] les catégories ne sont pas triées !

Trouvez ici tout l'aide dont vous avez besoin concernant le script d'annuaire Arfooo.
Merci de reporter les éventuels bugs trouvés.

Re: les catégories ne sont pas triées !

Messagede enligne » Mer 26 Jan 2011 01:20

Effectivement, on ne parle pas tous du même problème ...

Exemple : http://www.maxannu.com/webmaster-submit ... -free.html
Si vous sélectionnez "agences immobilières", le tri est incorrecte (non alphabétique)
je précise que dans l'admin, les sous catégories sont bien triées (alphabétique)

en listant le source de la page, je n'ai pas d'info, car la colonne s'actualise en fonction de la première ...

Il doit y avoir au niveau de l'affichage de la 2 eme colonne, une instruction a ajouter pour le tri !
Si quelqu'un a trouvé la solution, merci de la faire partager ou à ARF qui connait le système comme personne
de nous dénicher ce bout de code dont il a le secret ^^

Merci !

EDIT : J'ai effectué un test "ALTER TABLE `Arfooo_categories` ORDER BY `name`"
Cela a très bien fonctionné de mon côté :D

Une solution qui dépanne, merci, mais qui ne règle pas entièrement le problème ...
En effet, il faut faire la manipulation a chaque fois que l'on ajoute une sous catégorie non classée ^^

PS : La commande ALTER TABLE permet aussi de modifier la structure d’une table (changer les spécifications de la clé primaire ou ajouter une contrainte unique à une colonne).
Avatar de l’utilisateur
enligne
 
Messages: 181
Inscription: Lun 3 Jan 2011 17:24


Re: les catégories ne sont pas triées !

Messagede MaZzO » Mer 26 Jan 2011 11:32

Ok merci de la précision, je vais regarder cela de plus près :)

Edit : J'ai été sur la table concernée de phpmyadmin, n'étant pas connaisseur je ne comprends trop la manip. C'est possible de détailler un petit peu ou, quoi et comment faire cette modification ?

Merci d'avance :)
MaZzO
 
Messages: 104
Inscription: Ven 17 Déc 2010 15:20

Re: les catégories ne sont pas triées !

Messagede jjcc » Mer 26 Jan 2011 17:23

bonsoir
pour la manipe sur la base ,tu vas dans phpmyadmin et tu clic dans le menu sur sql ,tu as une fenêtre qui s'ouvre "exécuter une ou des requêtes sur la base/le nom de ta base" tu tapes
Code: Tout sélectionner
ALTER TABLE `Arfooo_categories` ORDER BY `name`
puis en bas de la fenêtre à droite sur exécuter et c'est tout ..Cela a pour effet de remettre tes catégories et sous/catégories dans l'ordre
tient une ptite question ,quelle requête utiliser pour les mots-clés (en désordre complet) merci
@ pluche
jjcc
 
Messages: 159
Inscription: Ven 25 Avr 2008 07:54
Localisation: La Rochelle

Re: les catégories ne sont pas triées !

Messagede MaZzO » Mer 26 Jan 2011 18:31

Je te remercie pour la réponse, je vais tester cela de suite :)

Edit : Nickel, ca fonctionne très bien :)
MaZzO
 
Messages: 104
Inscription: Ven 17 Déc 2010 15:20

Re: les catégories ne sont pas triées !

Messagede Arf » Jeu 27 Jan 2011 13:01

Sinon pour que ça reste en place après la création de nouvelle catégories ^^
Enfin le bouton sur la page index de l'admin sera utile ^^

dans le dossier controller/CategoryController.php
line 119

Code: Tout sélectionner
$c->addOrder("position");   


Ajouter après :

Code: Tout sélectionner
         $c->addOrder("name");   


Donc au final on a :
Code: Tout sélectionner
        $c = new Criteria();
        $c->addOrder("position");
        $c->addOrder("name");


Voilou, rien de plus simple ;)
Arf
Administrateur du site
 
Messages: 3097
Inscription: Lun 21 Jan 2008 14:53

Re: les catégories ne sont pas triées !

Messagede enligne » Jeu 27 Jan 2011 13:25

enligne a écrit:ARF qui connait le système comme personne
de nous dénicher ce bout de code dont il a le secret ^^


Voila un bout de code qui sera utile ^^

Merci
Avatar de l’utilisateur
enligne
 
Messages: 181
Inscription: Lun 3 Jan 2011 17:24

Re: les catégories ne sont pas triées !

Messagede MaZzO » Jeu 27 Jan 2011 15:49

Merci beaucoup Arf, effectivement cela évitera des manips supplémentaires :lol:
MaZzO
 
Messages: 104
Inscription: Ven 17 Déc 2010 15:20

Re: [Résolu] les catégories ne sont pas triées !

Messagede florent93 » Ven 20 Mai 2011 15:57

Apres la modification cité par Arf effectivement ça marche. mais j'ai remarquer un autre problème d'ordre alphabétique.

Quand je fais recherche avancée , il y a "Catégories" qui apparait en dessous avec une liste déroulante appelée "Toutes les catégories"


et dans cette liste la les catégories sont ranger par ordre de creation des catégories dans admin/site et categorie.
florent93
 
Messages: 2
Inscription: Mer 11 Mai 2011 08:51

Précédente

Retourner vers Installation, aide et report de bugs

 


  • Articles en relation
    Réponses
    Vus
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 0 invités

 
Copyright © arfooo.com  2007 - 2011  -  Tous droits réservés  -  Partenaires de confiance
Sites du groupe: petites annonces gratuites   voyance en direct - tirage tarot   Consultant en référencement
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group | phpBB SEO Traduction par: phpBB-fr.com
cron