[Résolu] Edition/Validation sites Admin lente + page blanche

Trouvez ici tout l'aide dont vous avez besoin concernant le script d'annuaire Arfooo.
Merci de reporter les éventuels bugs trouvés.

[Résolu] Edition/Validation sites Admin lente + page blanche

Messagede onico0 » Sam 29 Mai 2010 11:49

Bonjour à tous,

Dans ce topic : topic2033-20.html je me plaignais dans plusieurs message de lenteurs et de plantage lorsqu'on administrait des sites dans l'admin. Arfooo.

Montée en flèche de la consommation du CPU, Ram+Swap et même, cela aboutissait à l'affichage d'une page blanche sur tout l'annuaire Arfooo, principalement lors des actions : validation d'un site, edition d'un site.

On me conseillait ici : post12907.html#p12907 de revoir la mémoire allouée à mes script PHP (voir php.ini de votre serveur)...

Sur mon serveur 1, elle était à 128 Mo, et ça plantait souvent... Redescendue à 64 Mo, ça plantait déjà moins...

J'ai déménagé de serveur... Sur ce Serveur 2, par défaut, la mémory limit de mon php.ini était à 16 Mo, ça plantait un peu de temps en temps. Sur ce serveur 2, je l'ai réglée à 32 Mo et maintenant tout va bien.

J'espère que mon retour d'expérience vous sera utile.
Webmaster expert WordPress, je propose aussi de l'hébergement Web sur Easy Hoster.
onico0
 
Messages: 387
Inscription: Lun 21 Sep 2009 13:49
Localisation: Agence Web Belgique


Re: [Résolu] Edition/Validation sites Admin lente + page blanche

Messagede Strez » Sam 29 Mai 2010 12:25

Tu es sur un dédié ou un mutualisé ?

Juste pour savoir chez qui :)
Outils pour le référencement à découvrir d'urgence - Annuaire de référencement pour une bonne indéxation ;)
Strez
 
Messages: 102
Inscription: Ven 28 Mai 2010 06:56
Localisation: Grenoble

Re: [Résolu] Edition/Validation sites Admin lente + page blanche

Messagede onico0 » Sam 29 Mai 2010 13:08

VDS Sivit ;)
Webmaster expert WordPress, je propose aussi de l'hébergement Web sur Easy Hoster.
onico0
 
Messages: 387
Inscription: Lun 21 Sep 2009 13:49
Localisation: Agence Web Belgique

Re: [Résolu] Edition/Validation sites Admin lente + page blanche

Messagede Strez » Sam 29 Mai 2010 14:06

A fort trafic tu dois manquer de Bp sans doute, c'est la rançon de la gloire faudra viser plus haut (mais plus cher encore que un dédié kimsufi ovh et pas beaucoup plus cher que la seconde formule :p ).

Personnellement sur un dédié qui héberge plusieurs sites ainsi que des services genre teamspeack je n'ai jamais ce genre de problème.
Outils pour le référencement à découvrir d'urgence - Annuaire de référencement pour une bonne indéxation ;)
Strez
 
Messages: 102
Inscription: Ven 28 Mai 2010 06:56
Localisation: Grenoble

Re: [Résolu] Edition/Validation sites Admin lente + page blanche

Messagede Arf » Dim 30 Mai 2010 11:56

Bonjour,

La mémoire allouée dépend également de la ram dispo sur ton serveur.
Derrière la ram sert aussi pour mysql par exemple.
Bref cela va dépendre de l'optimisation effectué lors du développement, du nombre de script sur le même serveur, et la charge du serveur à un moment t.
Puis j'aime pas les vds, trop souvent très mal config, pire que les mutus avec tous les boulets présents sur le net...
Arf
Administrateur du site
 
Messages: 3096
Inscription: Lun 21 Jan 2008 14:53

Re: [Résolu] Edition/Validation sites Admin lente + page blanche

Messagede onico0 » Dim 30 Mai 2010 15:51

Le principal c'est que ce retour donnera une piste à d'autres qui auraient le même problème. Il est vrai qu'il peut y avoir des souci avec les VDS, mais le prix est bien moindre que du dédié réel pour parfois, des performance qui peuvent être supérieurs ;) :)
Webmaster expert WordPress, je propose aussi de l'hébergement Web sur Easy Hoster.
onico0
 
Messages: 387
Inscription: Lun 21 Sep 2009 13:49
Localisation: Agence Web Belgique

Re: [Résolu] Edition/Validation sites Admin lente + page blanche

Messagede onico0 » Lun 31 Mai 2010 15:20

Bon ben ça m'est arrivé quelques fois lors d'une grande séance de validations.

Je l'ai monté à 64M de mémoire mais ça ne change rien... décidément :) Si vous avez quelques petites idées niveau config d'apache et/ou petite modif. niveau du coeur d'arfooo je suis preneur ;)

À la fin je me demande même si ça ne vient pas de certaines extensions dans mon firefox (souci d'interprétation js aléatoire p-e ? qui ferait planter mon arfooo...) parce que la personne qui édite l'annuaire avec moi n'engendre jamais le plantage de l'annuaire même s'il peut y avoir des latence dans l'admin. Je vais essayer de désactiver un max. d'extensions.

si vous avez des idées pour m'aider ... :D
Dernière édition par onico0 le Lun 31 Mai 2010 15:33, édité 1 fois.
Webmaster expert WordPress, je propose aussi de l'hébergement Web sur Easy Hoster.
onico0
 
Messages: 387
Inscription: Lun 21 Sep 2009 13:49
Localisation: Agence Web Belgique

Re: [Résolu] Edition/Validation sites Admin lente + page blanche

Messagede Hexa-67 » Lun 31 Mai 2010 15:32

onico0 a écrit:Bon ben ça m'est arrivé quelques fois lors d'une grande séance de validations.

Je l'ai monté à 64M de mémoire mais ça ne change rien... décidément :) Si vous avez quelques petites idées niveau config d'apache et/ou petite modif. niveau du coeur d'arfooo je suis preneur ;)



Salut,
moi j'ai un VDS aussi chez Sivit et qui tourne du tonnerre!
mises à jour régulières par ma pomme et tout fonctionne à merveille malgré un site bouffeur de bande passante. (Non, pas mon annuaire... ;) )

Pour bien voir tout ce qui se passe dessus, j'ai installé AwStats et Munin. Si ça peut t'aider...
Avatar de l’utilisateur
Hexa-67
 
Messages: 966
Inscription: Lun 1 Mar 2010 17:59

Re: [Résolu] Edition/Validation sites Admin lente + page blanche

Messagede onico0 » Lun 31 Mai 2010 15:35

bah c'est vraiment que la partie arfooo qui plante... j'ai un wordpress et un digg like sur le site qui plante pas... quand j'ai ce souci de page blanche, c'est tout l'annuaire arfooo qui est planté et qui renvoi une page blanche... mais pas le reste... et y a pas de trafic colossal du tout ;)

mais merci pour ton éclaircicemment

avant y avait aucun souci, mais bon, la BDD de mon annuaire commence à se faire un peu plus conséquente... peut-être est-ce lié
Webmaster expert WordPress, je propose aussi de l'hébergement Web sur Easy Hoster.
onico0
 
Messages: 387
Inscription: Lun 21 Sep 2009 13:49
Localisation: Agence Web Belgique

Re: [Résolu] Edition/Validation sites Admin lente + page blanche

Messagede onico0 » Dim 6 Juin 2010 12:41

Je donne des mes nouvelles.

J'avais réglé le memory_limit de mon php.ini à 32Mo sur mon petit VDS Sivit 512. Ça tournait pas trop mal... Mais quand même 2 pages blanches sur 100 sites validés. Donc 2% de bug on va dire... (surtout aux heures de pointe). Alors je l'ai poussé un tout petit peu plus haut puisque l'erreur étaient assez rare : 40Mo... Car 64Mo ça plantait tous les 2 sites validés (serveur trop faiblard).

Ça passe plutôt bien d'autant plus que j'ai diminué mon KeepAliveTimeOut de mon httpd.conf à moins de 5 secondes (15 par defaut), et le serveur tourne mieux dans sa globalité.

Morale de l'histoire, faute d'hébergement mutualisé, il faut un serveur avec pas mal de mémoire sur lequel poser arfooo. Je préconise 1024 Mo de mémoire, 512 Mo étant un peu limite, mais assez satisfaisant... mais si 512Mo, il faut pouvoir re-démarrer apache si le bug apparait pour éviter le drame d'une journée de page blanche pour votre annuaire.

Pour ma part, si ça m'enquiquine vraiment trop, j'upgraderais mon serveur.
Webmaster expert WordPress, je propose aussi de l'hébergement Web sur Easy Hoster.
onico0
 
Messages: 387
Inscription: Lun 21 Sep 2009 13:49
Localisation: Agence Web Belgique

Suivante

Retourner vers Installation, aide et report de bugs

 


  • Articles en relation
    Réponses
    Vus
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 0 invités

 
Copyright © arfooo.com  2007 - 2011  -  Tous droits réservés  -  Partenaires de confiance
Sites du groupe: petites annonces gratuites   voyance en direct - tirage tarot   Consultant en référencement
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group | phpBB SEO Traduction par: phpBB-fr.com
cron