probleme caractere, encodage ?

Trouvez ici tout l'aide dont vous avez besoin concernant le script d'annuaire Arfooo.
Merci de reporter les éventuels bugs trouvés.

probleme caractere, encodage ?

Messagede lelectronique » Jeu 4 Sep 2008 12:19

Bonjour,
je viens d'installer le script sur mon serveur suite à la mise à jour (oufff :) ) en PHP5 et MySQL5 mais j'ai un soucis avec les caractères comme si c'était un problème ISO uft8
a quoi cela peut il être du ?
merci d'avance
A+
ludo
lelectronique
 
Messages: 113
Inscription: Lun 18 Aoû 2008 08:48
Localisation: Tours


Re: probleme caractere, encodage ?

Messagede Arf » Jeu 4 Sep 2008 12:55

Bonjour,

Quel est l'adresse du site ?
C'est suite à une installation classique ou une migration ?

Arf.
Arf
Administrateur du site
 
Messages: 3082
Inscription: Lun 21 Jan 2008 14:53

Re: probleme caractere, encodage ?

Messagede lelectronique » Jeu 4 Sep 2008 14:48

bonjour,
en faite j'ai installé le script sur cette adresse www.lelectronique.com/annuaire/ et pour les tests j'ai renommé le répertoire en annuaire2 j'ai bien vu l'adresse en dur dans une des tables mais ensuite je ne sais pas trop :(
lelectronique
 
Messages: 113
Inscription: Lun 18 Aoû 2008 08:48
Localisation: Tours

Re: probleme caractere, encodage ?

Messagede lelectronique » Jeu 4 Sep 2008 17:27

bon je viens de refaire l'installation plus de soucis arf :( etrange...
pas contre j'ai cette erreur dans l'admin quand je clique sur setting
Code: Tout sélectionner
2) require_once(/home/web/lelectronique.com/ftp/www/annuaire/components/template_lite/plugins/function.html_options.php) [function.require-once]: failed to open stream: No such file or directory   c_1_setting_index_tpl.php   line 1     4-9-08   18:25 
FrontController->dispatch() # line   13, file: /home/web/lelectronique.com/ftp/www/annuaire2/index.php
  Controller->render() # line  337, file: /home/web/lelectronique.com/ftp/www/annuaire2/core/FrontController.php
    TemplateLiteView->render() # line  130, file: /home/web/lelectronique.com/ftp/www/annuaire2/core/Controller.php
      Template_Lite->fetch("setting/index.tpl") # line  265, file: /home/web/lelectronique.com/ftp/www/annuaire2/views/TemplateLiteView.php
        Template_Lite->_fetch_compile("setting/index.tpl", null) # line  552, file: /home/web/lelectronique.com/ftp/www/annuaire2/components/template_lite/class.template.php
          include("/home/web/lelectronique.com/ftp/www/annuaire2/compiled/admin/arf...") # line  681, file: /home/web/lelectronique.com/ftp/www/annuaire2/components/template_lite/class.template.php
            require_once() # line    1, file: /home/web/lelectronique.com/ftp/www/annuaire2/compiled/admin/arfooo_template/en/c_1_setting_index_tpl.php




sinon comment faire ensuite afin de changer d eplace le script de l'annuaire (/annuaire2/ vers /annuaire/) ?

Merci d'avance
A+
lelectronique
 
Messages: 113
Inscription: Lun 18 Aoû 2008 08:48
Localisation: Tours

Re: probleme caractere, encodage ?

Messagede Arf » Jeu 4 Sep 2008 18:20

Peut être un problème de fichier mal uploadé visiblement.
Essaye de upluadé de nouveaux les fichiers sinon vide également le dossier cache et compiled sauf les .htaccess

Pour déplacer il suffit de soit passer via setting pour changer l'url soit il faut passer via phpmyadmin.
Ensuite renommer le fichier annuaire2 en annuaire ou simplement uploadé tous les fichier dans le nouveau dossier.

Arf.
Arf
Administrateur du site
 
Messages: 3082
Inscription: Lun 21 Jan 2008 14:53

Re: probleme caractere, encodage ?

Messagede lelectronique » Jeu 4 Sep 2008 19:18

je viens de renvoyer le répertoire d'admin seulement, c'est rentré dans l'ordre coté admin mais les caractères étrange sont revenus arf cf http://www.lelectronique.com/annuaire2/
lelectronique
 
Messages: 113
Inscription: Lun 18 Aoû 2008 08:48
Localisation: Tours

Re: probleme caractere, encodage ?

Messagede Arf » Jeu 4 Sep 2008 19:27

Peut être que vous modifier les fichiers de templates et que vous les enregistrés en iso, alors que c'est de l'utf8 à l'origine l'encodage du fichier donc bug de caractère.

Si vous remettez les ficheir de template d'origine je suis sûr que le bug disparait.
Vous utilisez quoi comme editeur de texte ?
Vos mieux prendre un editeur comme notepad++ par exemple qui respecte l'encodage d'origine du fichier.
Arf
Administrateur du site
 
Messages: 3082
Inscription: Lun 21 Jan 2008 14:53

Re: probleme caractere, encodage ?

Messagede lelectronique » Jeu 4 Sep 2008 21:21

non cela ne change rien je viens de remettre la template par défaut même problème le truc étrange c'est que le pb est revenu lorsque j'ai remis le répertoire admin sur le serveur :(
lelectronique
 
Messages: 113
Inscription: Lun 18 Aoû 2008 08:48
Localisation: Tours

Re: probleme caractere, encodage ?

Messagede Arf » Jeu 4 Sep 2008 23:48

Pas de problème on va trouver :)

On va faire simple.
- Téléchargement de l'annuaire sur arfooo pour avoir un zip tout propre et neuf
- Supression de tous les fichiers sur votre serveur.
- Suppression de la base de données.

Installe toute propre de arfooo et surtout ne rien modifier !

Quel est votre hébergeur ?

Arf.
Arf
Administrateur du site
 
Messages: 3082
Inscription: Lun 21 Jan 2008 14:53

Re: probleme caractere, encodage ?

Messagede lelectronique » Ven 5 Sep 2008 09:33

voilà je viens de faire ce que tu m'as dit. Pas installé car si tu regarde http://www.lelectronique.com/annuaire2/install/ dans le champs de sélection de langue déjà la langue "français" à un caractère bizarre :(

pour répondre à ta question je suis chez sivit sur un serveur virtuel 512mo

merci pour ton aide
lelectronique
 
Messages: 113
Inscription: Lun 18 Aoû 2008 08:48
Localisation: Tours

Suivante

Retourner vers Installation, aide et report de bugs

 


  • Articles en relation
    Réponses
    Vus
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 0 invités

 
Copyright © arfooo.com  2007 - 2011  -  Tous droits réservés  -  Partenaires de confiance
Sites du groupe: petites annonces gratuites   voyance en direct - tirage tarot   Consultant en référencement
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group | phpBB SEO Traduction par: phpBB-fr.com