Problème encodage avec utf-8 et iso-8859-1

Trouvez ici tout l'aide dont vous avez besoin concernant le script d'annuaire Arfooo.
Merci de reporter les éventuels bugs trouvés.

Problème encodage avec utf-8 et iso-8859-1

Messagede phyl49 » Lun 26 Jan 2009 18:29

Bonsoir,
Je viens de découvrir cette annuaire et j'ai un problème avec les accents des l'installation, dont voici un exemple.
Il vous suffit de suivre les étapes d`installation et de rentrer les informations nécessaires.
Je régle mon encodage sur utf-8 et à la page suivante il revient en iso-8859-1. Cela fait deux jour que je cherche sur le forum et je ne trouve pas la réponse. j'utilise la dernière version de l'annuaire arfooo-1.0.8 . Je trouve l'annuaire super et je voudrais bien l'utiliser. Si quelqu'un à la solution de mon problème, je suis preneur. Merci de vos réponses et bonne soirée
Phyl49
--------
phylderadio - Hits des années 70 à ce jour
Tous les hommes aiment à s'approprier le bien d'autrui; c'est un sentiment général; la manière seule de le faire est différente. [Lesage Alain Rene]
phyl49
 
Messages: 22
Inscription: Lun 26 Jan 2009 11:38
Localisation: Angers - Maine et Loire


Re: Problème encodage avec utf-8 et iso-8859-1

Messagede Alimata » Lun 26 Jan 2009 20:41

Pour l'install c'est pas ben grave
Sur le site en ligne c'est pareil ?
Alimata
 
Messages: 38
Inscription: Mer 17 Déc 2008 21:27
Localisation: Panam

Re: Problème encodage avec utf-8 et iso-8859-1

Messagede phyl49 » Mar 27 Jan 2009 18:27

Oui Idem
Phyl49
--------
phylderadio - Hits des années 70 à ce jour
Tous les hommes aiment à s'approprier le bien d'autrui; c'est un sentiment général; la manière seule de le faire est différente. [Lesage Alain Rene]
phyl49
 
Messages: 22
Inscription: Lun 26 Jan 2009 11:38
Localisation: Angers - Maine et Loire

Re: Problème encodage avec utf-8 et iso-8859-1

Messagede Arf » Mar 27 Jan 2009 18:41

Bonjour,

Quel type de serveur avez-vous ?
Dédié, mutualisé, virtuel ?

Je suis presque sûr, que la config apache doit retourner par défaut dans le header du iso8859-1 alors qu'il devrait retourner par défaut, rien ;)
Arf
Administrateur du site
 
Messages: 3097
Inscription: Lun 21 Jan 2008 14:53

Re: Problème encodage avec utf-8 et iso-8859-1

Messagede phyl49 » Mar 27 Jan 2009 19:58

Mutualisé
dans le phpinfos il marque
Code: Tout sélectionner
default_charset   iso-8859-1
Phyl49
--------
phylderadio - Hits des années 70 à ce jour
Tous les hommes aiment à s'approprier le bien d'autrui; c'est un sentiment général; la manière seule de le faire est différente. [Lesage Alain Rene]
phyl49
 
Messages: 22
Inscription: Lun 26 Jan 2009 11:38
Localisation: Angers - Maine et Loire

Re: Problème encodage avec utf-8 et iso-8859-1

Messagede Arf » Mar 27 Jan 2009 20:15

Quel est ton hébergeur, qu'on aille le fouetter ?
Arf
Administrateur du site
 
Messages: 3097
Inscription: Lun 21 Jan 2008 14:53

Re: Problème encodage avec utf-8 et iso-8859-1

Messagede phyl49 » Mar 27 Jan 2009 20:20

Mon hébergeur est Yellis.net http://www.yellis.net,
Phyl49
--------
phylderadio - Hits des années 70 à ce jour
Tous les hommes aiment à s'approprier le bien d'autrui; c'est un sentiment général; la manière seule de le faire est différente. [Lesage Alain Rene]
phyl49
 
Messages: 22
Inscription: Lun 26 Jan 2009 11:38
Localisation: Angers - Maine et Loire

Re: Problème encodage avec utf-8 et iso-8859-1

Messagede phyl49 » Jeu 29 Jan 2009 09:01

Bonjour,
j'ai contacté par mon hébergeur par mail et il me dit de mettre dans le htaccess :
Code: Tout sélectionner
AddDefaultcharset On
AddType 'text/html; charset=UTF-8' html


Mais pour l'instant ça ne fonctionne pas, je l'ai placé au début du fichier
Code: Tout sélectionner
AddDefaultcharset utf-8
AddType 'text/html; charset=UTF-8' html

#You may need to un-comment the following line
#Options +FollowSymlinks

# REMEBER YOU ONLY NEED TO STARD MOD REWRITE ONCE
RewriteEngine On

#REWRITE BASE
#RewriteBase /

# HERE IS A GOOD PLACE TO ADD THE WWW PREFIXE REDIRECTION


# HERE IS A GOOD PLACE TO ADD THE OLD SCRIPT REDIRECTION
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.+)$ index.php


Bonne journée
Phyl49
--------
phylderadio - Hits des années 70 à ce jour
Tous les hommes aiment à s'approprier le bien d'autrui; c'est un sentiment général; la manière seule de le faire est différente. [Lesage Alain Rene]
phyl49
 
Messages: 22
Inscription: Lun 26 Jan 2009 11:38
Localisation: Angers - Maine et Loire

Re: Problème encodage avec utf-8 et iso-8859-1

Messagede Arf » Jeu 29 Jan 2009 18:36

Bonjour,

J'ai déjà vu cette commande et je l'ai testé sans succès également...
C'est à eux de changer leur config apache de mauvaise qualité...
Je ne peux absolument rien faire pour ça.
Arf
Administrateur du site
 
Messages: 3097
Inscription: Lun 21 Jan 2008 14:53

Re: Problème encodage avec utf-8 et iso-8859-1

Messagede phyl49 » Ven 30 Jan 2009 07:31

Bonjour,
Code: Tout sélectionner
Je ne peux absolument rien faire pour ça.
Si je change hébergement, j'ai regardé sur Ovh avec un plan mutualisé 90plan dans le php le " default_charset no value " je pense que je n'aurais plus de problème avec les utf-8. Bonne journée
Phyl49
--------
phylderadio - Hits des années 70 à ce jour
Tous les hommes aiment à s'approprier le bien d'autrui; c'est un sentiment général; la manière seule de le faire est différente. [Lesage Alain Rene]
phyl49
 
Messages: 22
Inscription: Lun 26 Jan 2009 11:38
Localisation: Angers - Maine et Loire

Suivante

Retourner vers Installation, aide et report de bugs

 


  • Articles en relation
    Réponses
    Vus
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 0 invités

 
Copyright © arfooo.com  2007 - 2011  -  Tous droits réservés  -  Partenaires de confiance
Sites du groupe: petites annonces gratuites   voyance en direct - tirage tarot   Consultant en référencement
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group | phpBB SEO Traduction par: phpBB-fr.com
cron