mod_rewrite (résolu)

Trouvez ici tout l'aide dont vous avez besoin concernant le script d'annuaire Arfooo.
Merci de reporter les éventuels bugs trouvés.

mod_rewrite (résolu)

Messagede zioup2 » Mer 29 Oct 2008 12:28

Apparemment, le mod_rewrite ne semble pas actif chez mon hébergeur... Arfoo ne fonctionne pas sans ce mod_rewrite?
Parce que, aprés avoir installé le script, il est impossible d'aller dans l'admin (500...)

Merci pour votre réponse

Version 1.07
Dernière édition par zioup2 le Jeu 30 Oct 2008 09:34, édité 1 fois.
- Version 1.07 -
zioup2
 
Messages: 28
Inscription: Mer 29 Oct 2008 11:43


Re: mod_rewrite

Messagede Arf » Mer 29 Oct 2008 12:37

Bonjour,
Quel est votres hébergeur ?
En général le mod_rewrite est souvent activé mais il faut parfois modifier un peu le fichier htaccess

Sinon Arfooo fonctionne sans le mod rewrite mais il faut modifier le fichier install ou aller dans la base de données pour mettre l'url rewrting à 0.

Si le mod_rewrite n'est pas activé, j'expliquerai comment faire ça très simplement.
Arf
Administrateur du site
 
Messages: 3082
Inscription: Lun 21 Jan 2008 14:53

Re: mod_rewrite

Messagede zioup2 » Mer 29 Oct 2008 13:52

Ouaouh, super, alors je vais essayer dans la base de donnéees, sinon, je veux bien que vous me disiez comment faire dans l'install. (hébergeur 1and1)
Merci
- Version 1.07 -
zioup2
 
Messages: 28
Inscription: Mer 29 Oct 2008 11:43

Re: mod_rewrite

Messagede Keroin » Mer 29 Oct 2008 14:44

Pour activer le php5 chez 1&1 il faut ajouter une ligne dans ton htaccess
=> post3752.html#p3752
Les Pages du Keroinsite - Annuaire généraliste gratuit : http://pages.keroinsite.com
Keroin
 
Messages: 192
Inscription: Mar 15 Juil 2008 15:48

Re: mod_rewrite

Messagede zioup2 » Mer 29 Oct 2008 15:59

Pour le php5, j'ai mis ...AddType x-mapp-php5 .php..... dans .htaccess.
C'est le mod_rewrite que je souhaite désactiver.
Merci
- Version 1.07 -
zioup2
 
Messages: 28
Inscription: Mer 29 Oct 2008 11:43

Re: mod_rewrite

Messagede Keroin » Mer 29 Oct 2008 16:18

Ah ok mais les erreurs 500 sont souvent due à une non activation du php5 c'est pour ça que j'ai donné ça.
Si tu es sur mutualisé chez 1&1, le mod rewrite est actif par défaut (pour serveur dédié voir ton fichier de config php.ini)
Le début de ton htaccess doit ressembler à ça sur un mutu 1&1
Code: Tout sélectionner
# Put the line here to enable PHP5
AddType x-mapp-php5 .php

# You may need to un-comment the following line
Options +FollowSymlinks

# REMEBER YOU ONLY NEED TO STARD MOD REWRITE ONCE
RewriteEngine On

# REWRITE BASE
RewriteBase /


Il faut bien décommenter le # devant RewriteBase sinon ça ne passe pas ;)
Les Pages du Keroinsite - Annuaire généraliste gratuit : http://pages.keroinsite.com
Keroin
 
Messages: 192
Inscription: Mar 15 Juil 2008 15:48

Re: mod_rewrite

Messagede zioup2 » Mer 29 Oct 2008 17:06

c'est exactement ce que j'ai et le mod_rewrite n'étant toujours pas activé....
J'ai essayé de faire comme me l'a soufflé ARF... modifier dans la base de données en le mettant sur 0, et c'est toujours pareil.... j'ai Error 404 - Not found...

Merci
- Version 1.07 -
zioup2
 
Messages: 28
Inscription: Mer 29 Oct 2008 11:43

Re: mod_rewrite

Messagede Arf » Mer 29 Oct 2008 17:35

Vous avez quelle offre chez 1&1 ?
Il vaut mieux réactiver l'url rewriting dans votre base de données.
Ensuite supprimer le contenu du dossier cache sauf le htaccess

Sinon vous en êtes où ?
Vous avez réussi à installer arfooo ?
Où est installé arfooo ? dans un dossier ?

Arf.
Arf
Administrateur du site
 
Messages: 3082
Inscription: Lun 21 Jan 2008 14:53

Re: mod_rewrite

Messagede zioup2 » Mer 29 Oct 2008 18:23

Vous avez quelle offre chez 1&1 ?
J'ai le pack expert ... naturellement mutualisé.
Il vaut mieux réactiver l'url rewriting dans votre base de données.
C'est fait, j'ai tout effacer et tout réinstallé.
Ensuite supprimer le contenu du dossier cache sauf le htaccess
C'est fait
Vous avez réussi à installer arfooo ?
Oui chez infomaniak en test, mais c'est chez 1and1 que je dois l'installer
Où est installé arfooo ? dans un dossier ?
Dans un répertoire nommé annuaire.
Ensuite à partir d'un sous-domaine, j'y accède.
Merci
- Version 1.07 -
zioup2
 
Messages: 28
Inscription: Mer 29 Oct 2008 11:43

Re: mod_rewrite

Messagede zioup2 » Mer 29 Oct 2008 19:48

Arf a écrit:...Sinon Arfooo fonctionne sans le mod rewrite mais il faut modifier le fichier install ou aller dans la base de données pour mettre l'url rewrting à 0.
Si le mod_rewrite n'est pas activé, j'expliquerai comment faire ça très simplement.

Et comment faire dans l'install pour le désactiver?
Merci
- Version 1.07 -
zioup2
 
Messages: 28
Inscription: Mer 29 Oct 2008 11:43

Suivante

Retourner vers Installation, aide et report de bugs

 


  • Articles en relation
    Réponses
    Vus
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 0 invités

 
Copyright © arfooo.com  2007 - 2011  -  Tous droits réservés  -  Partenaires de confiance
Sites du groupe: petites annonces gratuites   voyance en direct - tirage tarot   Consultant en référencement
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group | phpBB SEO Traduction par: phpBB-fr.com
cron