Problème avec le moteur de recherche [Arfooo v.2.0.0]

Trouvez ici tout l'aide dont vous avez besoin concernant le script d'annuaire Arfooo.
Merci de reporter les éventuels bugs trouvés.

Re: Problème avec le moteur de recherche [Arfooo v.2.0.0]

Messagede Arf » Mar 22 Juin 2010 11:11

Oui c'est vrai, ça provient du fait que les réglages du moteur de recherche dans l'admin ne fonctionne pas.
C'est hard codé, j'ai merdé et on me l'a signalé.
Ce sera corrigé pour la prochaine version.
C'est surement le "AND", par conséquent il recherche tous les mots et ici si tu cherches uniquement "de" alors t'as le même résultat.
C'est tout bête, en utilisant "OR" le problème ne se poserait pas ici.

Tu peux toujours modifier le fichier
models/SiteSearcherModel.php en attendant
ligne 24
Code: Tout sélectionner
$booleanOperator = Config::get("searchEngineWordDefaultOperator") == "AND" ? "+" : "";

tu changes AND par OR par exemple ;)
Puis tu peux modifier quelques petits trucs si tu t'y connais un minimum.
Arf
Administrateur du site
 
Messages: 3082
Inscription: Lun 21 Jan 2008 14:53


Re: Problème avec le moteur de recherche [Arfooo v.2.0.0]

Messagede perle » Mar 22 Juin 2010 15:08

bonjour ,

quelle difference entre AND et OR

Cordialement Perle
Avatar de l’utilisateur
perle
 
Messages: 213
Inscription: Ven 14 Mar 2008 15:25

Précédente

Retourner vers Installation, aide et report de bugs

 


  • Articles en relation
    Réponses
    Vus
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 0 invités

 
Copyright © arfooo.com  2007 - 2011  -  Tous droits réservés  -  Partenaires de confiance
Sites du groupe: petites annonces gratuites   voyance en direct - tirage tarot   Consultant en référencement
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group | phpBB SEO Traduction par: phpBB-fr.com
cron