[RÉSOLU] Problème suite à changement de serveurs

Trouvez ici tout l'aide dont vous avez besoin concernant le script d'annuaire Arfooo.
Merci de reporter les éventuels bugs trouvés.

[RÉSOLU] Problème suite à changement de serveurs

Messagede HarmonieTerre » Jeu 22 Avr 2010 16:38

J'ai bien vu le topic http://forum.arfooo.com/topic796.html sur un problème similaire mais je me demandais si vos réponse avec Filezilla était toujours d'actualité ? eST-CE QU'IL PEUT Y AVOIR UNE AUTRE CAUSE ?

J'ai ce message d'erreur sur l'index du site donc il n'est plus du toit accessible :evil:

Code: Tout sélectionner
  (8) unserialize() [function.unserialize]: Error at offset 874 of 947 bytes   Cacher.php   line 173     22-4-10   10:53

FrontController->dispatch() # line   18, file: /home/sitexxxxxx/public_html/harmonieterre.net/index.php
  call_user_func_array(Array[2], Array[0]) # line  211, file: /home/sitexxxxx/public_html/harmonieterre.net/core/FrontController.php
    MainController->indexAction() # line    0, file: unknown
      Cacher->load("directoryDescription") # line   30, file: /home/sitexxxxxx/public_html/harmonieterre.net/controllers/MainController.php
        unserialize("a:6:{s:9:"messageId";s:20:"directoryDescription";s:5:"title";s:5...") # line  173, file: /home/sitexxxxxxx/public_html/harmonieterre.net/core/Cacher.php


J'ai quitté OVH pour Hostpapa. Ce n'est pas moi qui ait fait le transfert et je n'arrive pas à joindre le gars en question ;o(.

Par ou dois-je commencer ?
Quels sont les fichiers à modifier en cas de transfert de ce genre ?

Merci.
Dernière édition par HarmonieTerre le Mar 4 Mai 2010 21:07, édité 1 fois.
Annuaire Environnement des Entreprises écologiques, Services et Solutions durables
http://www.harmonieterre.net
HarmonieTerre
 
Messages: 162
Inscription: Mar 21 Avr 2009 00:08
Localisation: Canada/Québec


Re: [URGENT SVP] Problème suite à changement de serveurs

Messagede HarmonieTerre » Jeu 22 Avr 2010 18:43

Suite..

Après vidage du cache le message a changé mais j'ai toujours une grosse erreur :

Code: Tout sélectionner
  (8) Undefined index: advancedUrlRewritingEnabled   main.php   line 19     22-4-10   13:39

AppRouter->__construct() # line   17, file: /home/site6581/public_html/harmonieterre.net/index.php
  Router->addRewrites("/home/site6581/public_html/harmonieterre.net/config/rewrite.php") # line   22, file: /home/site6581/public_html/harmonieterre.net/components/AppRouter.php
    require("/home/site6581/public_html/harmonieterre.net/config/rewrite.php") # line   42, file: /home/site6581/public_html/harmonieterre.net/core/Router.php
      Config->get("advancedUrlRewritingEnabled") # line  127, file: /home/site6581/public_html/harmonieterre.net/config/rewrite.php


Sur mon cpanel voici les infos du serveur :

    Sub Section Directive Info Value
    Language Options asp_tags Allow ASP-style <% %> tags. Off
    File Uploads file_uploads Whether to allow HTTP file uploads. On
    Paths and Directories include_path Windows: "\path1;\path2" c:\php\includes" .:/usr/lib/php:/usr/local/lib/php
    Resource Limits max_execution_time Maximum execution time of each script, in seconds 30
    Resource Limits max_input_time Maximum amount of time each script may spend parsing request data 60
    Resource Limits memory_limit Maximum amount of memory a script may consume (32MB) 32M
    Data Handling register_globals You should do your best to write your scripts so that they do not require register_globals to be on; Using form variables as globals can easily lead to possible security problems, if the code is not very well thought of. Off
    Language Options safe_mode Off
    main session.save_path where N is an integer. Instead of storing all the session files in /path, what this will do is use subdirectories N-levels deep, and store the session data in those directories. This is useful if you or your OS have problems with lots of files in one directory, and is a more efficient layout for servers that handle lots of sessions. NOTE 1: PHP will not create this directory structure automatically. You can use the script in the ext/session dir for that purpose. NOTE 2: See the section on garbage collection below if you choose to use subdirectories for session storage /tmp
    File Uploads upload_max_filesize Maximum allowed size for uploaded files. 32M

Est-ce que c'est correcte pour Arfooo ?
Faut-il changer qq chose ?
Mon site est down. Merci de vos lumières...
Annuaire Environnement des Entreprises écologiques, Services et Solutions durables
http://www.harmonieterre.net
HarmonieTerre
 
Messages: 162
Inscription: Mar 21 Avr 2009 00:08
Localisation: Canada/Québec

Re: [URGENT SVP] Problème suite à changement de serveurs

Messagede onico0 » Jeu 22 Avr 2010 19:20

aucune idée de ton souci, mais je te suggère

- de lire ta table arfooo_setting avec phpmyadmin pour vérifier que rien n'eveil tes soupcon, genre, le chemin /home/tonsite/www/etc/.../
- de nous poster ton htaccess

garde ton calme ;-) la patience est mère de sureté tu vas trouver ;)
Webmaster expert WordPress, je propose aussi de l'hébergement Web sur Easy Hoster.
onico0
 
Messages: 387
Inscription: Lun 21 Sep 2009 13:49
Localisation: Agence Web Belgique

Re: [URGENT SVP] Problème suite à changement de serveurs

Messagede patrick » Jeu 22 Avr 2010 21:44

onico0 a écrit:
- de lire ta table arfooo_setting avec phpmyadmin pour vérifier que rien n'eveil tes soupcon, genre, le chemin /home/tonsite/www/etc/.../



Ca sent en effet le problème d'URL ça... ou des fichiers manquants
patrick
 
Messages: 21
Inscription: Sam 10 Avr 2010 23:06
Localisation: Belgique (une fois...)

Re: [URGENT SVP] Problème suite à changement de serveurs

Messagede HarmonieTerre » Ven 23 Avr 2010 16:41

merci de vos lumières.

Je n'ai rien trouvé sur arfooo_setting de louche (mais je ne suis pas un expert). J'ai regarder dans la colonne "value". C'est ça ? Les seuls urls sont clairement identifié http;//www....

Du côté des fichiers manquants apparemment c'est aussi ok mais là aussi prendre les sous-rep un par un pour vérifier l'état de chaue fichier... bonjour le job ! De se côté là Arf a pas fait dans la simplicité. Plus de 2000 fichiers a passer un par un, il y a de quoi faire une crise...

voici mon .htaccess

Code: Tout sélectionner
#Put the line here to enable PHP5
SetEnv PHP_VER 5

#You may need to un-comment the following line

#Options +FollowSymlinks
# REMEBER YOU ONLY NEED TO STARD MOD REWRITE ONCE
RewriteEngine On

#REWRITE BASE
#RewriteBase /

# HERE IS A GOOD PLACE TO ADD THE WWW PREFIXE REDIRECTION

# HERE IS A GOOD PLACE TO ADD THE OLD SCRIPT REDIRECTION
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.+)$ index.php


Compte tenu du message d'erreur je me demande si il ne faudrait pas chercher du côté du serveur qui n'autoriserait pas le rewriting. Il me semblait qu'il y avait des trucs à régler quand j'étais sur OVH aussi. Je m'en souviens plus. Quand ça marche on pense plus à ces conn.....

Question :
Dans quel fichier(s) sont inscrit les renseignements sur la base de donnée ? En clair quel est celui(ceux) que je ne dois pas effacer en faisant une réinstall des fichiers d'origine ?

Merci du coup de main


Mise à jour parce que je viens de trouver une première erreur dans le db.php : le prefixe de la base n'était pas bon !!! (pour ceux qui ne connaissent pas mes essais, j'ais installé plusieurs arfooo sur la même base. Cela fonctionne bien sauf qu'il faut pas se planter sur le db.php)

Il reste encore des erreurs. Notamment :

Code: Tout sélectionner
(256) TPL: [in includes/footer.tpl line 25]: syntax error: var function does not exist (class.compiler.php, line 501)   class.template.php   line 703

suivi d'un paquet de lignes....

Bon celle-là je viens de la résoudre aussi (je m'auto-dépanne mais je donne quand même l'info qui peut être utile à d'autres maladroits comme moi ;o)

C'est un problème avec le code javascript de Google Analytics. J'ai trouvé la réponse sur le topic 12262http://forum.arfooo.com/post12262.html il faut mettre le code entre les balises {literal} et {/literal}


Bon je continue les tests. Si vous voulez jeter un coup d'oeil et me dire ce qui clocherai, l'annuaire est ici : http://www.harmonieterre.net/
A+
Dernière édition par HarmonieTerre le Ven 23 Avr 2010 18:31, édité 1 fois.
Annuaire Environnement des Entreprises écologiques, Services et Solutions durables
http://www.harmonieterre.net
HarmonieTerre
 
Messages: 162
Inscription: Mar 21 Avr 2009 00:08
Localisation: Canada/Québec

Suites Problème suite à changement de serveurs

Messagede HarmonieTerre » Ven 23 Avr 2010 18:18

Bon le gros problème a été résolu par l'erreur dans le db.php

Maintenant j'ai une papardelle de petit truc qui fonctionne pas ou plus...

Sur le site lui même http://www.harmonieterre.net/ tout semble bien sauf que les vignettes des fiches qui n'ont pas de site (ou qui ont choisis une image au lieu du thumb) ont disparu !

Je ne trouve pas de traces de ces images. Dans quelle répertoire devraient-elles être ?
upload/images_thumbs ? Si c'est le cas, pourquoi les thumb n'ont pas disparus non plus ? Je pense plutôt à un pointage vers un dossier qui n'est pas bon... Une idée ?

Du côtè de l'Admin là c'est moins rose ;o(

La page de login s'affiche mais après saisi du login/Pass j'obtiens :

Code: Tout sélectionner
/admin/main/index
http://www.harmonieterre.net/admin/main/logIn

suivi de :
Code: Tout sélectionner
(2) require_once(/homez.28/xxxxxxxxxx/harmonieterre.net/components/template_lite/plugins/block.capture.php) [function.require-once]: failed to open stream: No such file or directory   c_1_main_index_tpl.php   line 1     23-4-10   13:13

FrontController->dispatch() # line   18, file: /home/xxxxxx/public_html/harmonieterre.net/index.php
  Controller->render() # line  216, file: /home/xxxxxxxxxxxxxxxxx/public_html/harmonieterre.net/core/FrontController.php
    TemplateLiteView->render(Object:Admin_MainController) # line  167, file: /home/xxxxxxxx/public_html/harmonieterre.net/core/Controller.php
      Template_Lite->fetch("main/index.tpl") # line   75, file: /home/xxxxxxxxxx/public_html/harmonieterre.net/views/TemplateLiteView.php
        Template_Lite->_fetch_compile("main/index.tpl", null) # line  360, file: /home/xxxxxxxxxx/public_html/harmonieterre.net/components/template_lite/class.template.php
          include("/home/xxxxxxxxxxx/public_html/harmonieterre.net/compiled/admin/arfo...") # line  482, file: /home/xxxxxxxxxxxxxx/public_html/harmonieterre.net/components/template_lite/class.template.php
            require_once() # line    1, file: /home/xxx/public_html/harmonieterre.net/compiled/admin/arfooo_template/fr/c_1_main_index_tpl.php


Pfoooouuuuuuuu....Et dire qu'il y en a qui aime ça bouffer du code toute la journée ;o)


Une idée les gars ? les filles ???
Dernière édition par HarmonieTerre le Dim 2 Mai 2010 06:59, édité 1 fois.
Annuaire Environnement des Entreprises écologiques, Services et Solutions durables
http://www.harmonieterre.net
HarmonieTerre
 
Messages: 162
Inscription: Mar 21 Avr 2009 00:08
Localisation: Canada/Québec

Re: [URGENT SVP] Problème suite à changement de serveurs

Messagede chadon » Dim 25 Avr 2010 01:21

Bonjour tout le monde.

Je suis désolé de ne plus venir sur le forum mais je suis completement débordé par mes sites depuis quelques temps. Enfin puisque j'ai recu un appel au secours par MP de la part de HarmonieTerre me revoila. :P
Mes annuaires sont aussi un peu a l'abandon alors je suis un peu largué avec les nouvelles fonctions de Arfooo.

Dans la page nouveautés, j'ai comparé les sites qui avaient une vignette et ceux qui n'en avaient pas et j'ai remarqué dans le deuxieme cas que les liens vers les vignettes sont dans un sous dossier qui ne semble pas exister sur le serveur.

Exemple avec celui de "Sol'Air Conseil" :
http://www.harmonieterre.net/uploads/im ... e7cd04.jpg

Alors que les vignettes valides ont une adresse tel que:
http://www.harmonieterre.net/uploads/im ... bs/153.jpg

Il faudrait voir par FTP si ces dossiers existent vraiment et si les fichiers ont tous étés transférés.

Par FTP, as tu essayé de transferer tous les fichiers a nouveau en choisissant d'annuler l'écrasement des fichiers déja existants?

Sinon ton nouvel hébergeur offre bien toutes les fonctions requises pour faire tourner Arfooo?
http://script.arfooo.com/prerequis/
chadon
 
Messages: 320
Inscription: Jeu 23 Oct 2008 14:26
Localisation: Canada NB

Re: [URGENT SVP] Problème suite à changement de serveurs

Messagede Arf » Lun 26 Avr 2010 16:48

Bonjour,

Tu es chez quel hébergeur ?
Le CHOMOD sur les dossiers sont ok ?
On dirait qu'il n'arrivepas à créer ou écrire dans les dossiers compiled.
Arf
Administrateur du site
 
Messages: 3082
Inscription: Lun 21 Jan 2008 14:53

Re: [URGENT SVP] Problème suite à changement de serveurs

Messagede HarmonieTerre » Dim 2 Mai 2010 06:38

Je suis chez Hostpapa. Il me semble que tout est correct de ce côté là.
Le CHMOD sur Compiled est 777
Les sous répertoires à l'intérieur sont 755
Correct ?

Pour la Version 2.0 aucun de mes templates ne fonctionnaient je me suis donc contenté
de personnaliser le Arfooo de base. Il ne devrait donc pas y avoir de pb de template dans
ce cas.

Voici mon message d'erreur lorsque je tente de me connecter à l'admin :

Code: Tout sélectionner
   (2) require_once(/homez.28/harmonier/harmonieterre.net/components/template_lite/plugins/block.capture.php) [function.require-once]: failed to open stream: No such file or directory   c_1_main_index_tpl.php   line 1     3-5-10   11:43

Suivi de plusieurs lignes...


J'ai un problème presque similaire avec le second annuaire : http://www.distributeurs-lifewave.net qui lui est resté en 1.0.9

J'arrive a accéder à l'admin mais pas à certains onglets ou j'obtiens quasiment le même message :

Si je clique sur Configuration:
Code: Tout sélectionner
(2) require_once(/homez.28/harmonier/distributeurs-lifewave.net/components/template_lite/plugins/function.html_options.php) [function.require-once]: failed to open stream: No such file or directory   c_1_setting_index_tpl.php   line 1


Si je clique sur Publicité :
Code: Tout sélectionner
   (2) require_once(/homez.28/harmonier/distributeurs-lifewave.net/components/template_lite/plugins/function.cycle.php) [function.require-once]: failed to open stream: No such file or directory   c_1_ad_index_tpl.php   line 1     2-5-10   1:43


Si je clique sur Template :
Code: Tout sélectionner
   (2) require_once(/homez.28/harmonier/distributeurs-lifewave.net/components/template_lite/plugins/function.cycle.php) [function.require-once]: failed to open stream: No such file or directory   c_1_template_index_tpl.php   line 1     2-5-10   1:44


Si je clique sur Utilisateurs, Plugins et Système je n'ai pas d'erreurs.

Le problème c'est que n'ayant pas accès à mes admin, cela commence à me mettre en retard ;o(

Est-ce que supprimer toute traces de mes anciens Templates pourrait résoudre le problème ?
Va-t-il basculer sur le template par défaut automatiquement ?
Quels fichiers effacer ?

Merci d'un coup de main.

PS: Pour les vignettes, effectivement Chadon le répertoire et les images ont disparues. Bizarre ce sont uniquement les images qui ne sont pas des thumbs de page web qui ont été effacé.
Annuaire Environnement des Entreprises écologiques, Services et Solutions durables
http://www.harmonieterre.net
HarmonieTerre
 
Messages: 162
Inscription: Mar 21 Avr 2009 00:08
Localisation: Canada/Québec

Re: [URGENT SVP] Problème suite à changement de serveurs

Messagede HarmonieTerre » Lun 3 Mai 2010 17:03

Personne n'a une idée ?????
Annuaire Environnement des Entreprises écologiques, Services et Solutions durables
http://www.harmonieterre.net
HarmonieTerre
 
Messages: 162
Inscription: Mar 21 Avr 2009 00:08
Localisation: Canada/Québec

Suivante

Retourner vers Installation, aide et report de bugs

 


  • Articles en relation
    Réponses
    Vus
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 0 invités

 
Copyright © arfooo.com  2007 - 2011  -  Tous droits réservés  -  Partenaires de confiance
Sites du groupe: petites annonces gratuites   voyance en direct - tirage tarot   Consultant en référencement
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group | phpBB SEO Traduction par: phpBB-fr.com